strongSwan VPN Client icon

2.5.1 by strongSwan Project


Feb 26, 2024

About strongSwan VPN Client

An easy to use IKEv2/IPsec-based VPN client.

Official Android port of the popular strongSwan VPN solution.

# FEATURES AND LIMITATIONS #

* Uses the VpnService API featured by Android 4+. Devices by some manufacturers seem to lack support for this - strongSwan VPN Client won't work on these devices!

* Uses the IKEv2 key exchange protocol (IKEv1 is *not* supported)

* Uses IPsec for data traffic (L2TP is *not* supported)

* Full support for changed connectivity and mobility through MOBIKE (or reauthentication)

* Supports username/password EAP authentication (namely EAP-MSCHAPv2, EAP-MD5 and EAP-GTC) as well as RSA/ECDSA private key/certificate authentication to authenticate users, EAP-TLS with client certificates is also supported

* Combined RSA/ECDSA and EAP authentication is supported by using two authentication rounds as defined in RFC 4739

* VPN server certificates are verified against the CA certificates pre-installed or installed by the user on the system. The CA or server certificates used to authenticate the server can also be imported directly into the app.

* IKEv2 fragmentation is supported if the VPN server supports it (strongSwan does so since 5.2.1)

* Split-tunneling allows sending only certain traffic through the VPN and/or excluding specific traffic from it

* Per-app VPN allows limiting the VPN connection to specific apps, or exclude them from using it

* The IPsec implementation currently supports the AES-CBC, AES-GCM, ChaCha20/Poly1305 and SHA1/SHA2 algorithms

* Passwords are currently stored as cleartext in the database (only if stored with a profile)

* VPN profiles may be imported from files

* Supports managed configurations via enterprise mobility management (EMM)

Details and a changelog can be found on our docs: https://docs.strongswan.org/docs/5.9/os/androidVpnClient.html

# PERMISSIONS #

* READ_EXTERNAL_STORAGE: Allows importing VPN profiles and CA certificates from external storage on some Android versions

* QUERY_ALL_PACKAGES: Required on Android 11+ to select apps to ex-/include in VPN profiles and the optional EAP-TNC use case

# EXAMPLE SERVER CONFIGURATION #

Example server configurations may be found in our docs: https://docs.strongswan.org/docs/5.9/os/androidVpnClient.html#_server_configuration

Please note that the host name (or IP address) configured with a VPN profile in the app *must be* contained in the server certificate as subjectAltName extension.

# FEEDBACK #

Please post bug reports and feature requests via GitHub: https://github.com/strongswan/strongswan/issues/new/choose

If you do so, please include information about your device (manufacturer, model, OS version etc.).

The log file written by the key exchange service can be sent directly from within the application.

What's New in the Latest Version 2.5.1

Last updated on Feb 26, 2024

# 2.5.1 #

- Fix for existing shortcuts and automation via Intents

# 2.5.0 #

- Support for managed configurations via enterprise mobility management (EMM)

Translation Loading...

Additional APP Information

Latest Version

Request strongSwan VPN Client Update 2.5.1

Uploaded by

Angela Patricia Osorio Ortiz

Requires Android

Android 5.0+

Available on

Get strongSwan VPN Client on Google Play

Show More

strongSwan VPN Client Screenshots

Comment Loading...
Languages
Searching...
Subscribe to APKPure
Be the first to get access to the early release, news, and guides of the best Android games and apps.
No thanks
Sign Up
Subscribed Successfully!
You're now subscribed to APKPure.
Subscribe to APKPure
Be the first to get access to the early release, news, and guides of the best Android games and apps.
No thanks
Sign Up
Success!
You're now subscribed to our newsletter.